Choose your language

Expressive E - macOS 10.15 Compatibility

Expressive E's software and hardware products are not supported under macOS 10.15 for the time being. Please refrain from installing macOS 10.15 on you Mac if you are using Touché, Lié or Arché.

Expressive E is currently running tests to offer full compatibility as soon as possible after the official release. Please check back this page or the general compatibility article of the respective product to obtain up-to-date information concerning the OS requirements of Expressive E's products